Android P或将停止支持Android 4.1及更早版本的应用

  • 时间:
  • 浏览:1
  • 来源:5分排列3娱乐平台-5分排列3下注平台_5分排列3注册平台

IT之家3月19日消息 最近,谷歌在一份文件中提示,Android 4.1及其如果版本的应用将无法在Android P上运行。如果IT之家报道了谷歌将在安卓9.0中限制应用的API的访问权限。如果新提交到Play商店的应用前要针对不超过一年如果的安卓版本,即安卓8.0。

最新的细节显示,谷歌在SDK中增加了一项MIN_SUPPORTED_TARGET_SDK_INT,规定了应用tcp连接支持的最低SDK版本。低于该版本的应用tcp连接将无法安装、运行。在Android P(安卓9.0)中,最低SDK版本为v17,即Android 4.2。

此外,新提交到Play商店的应用前要针对不超过一年如果的安卓版本,即安卓8.0。

有外媒在虚拟机中进行了试验。在虚拟机上运行的预览版Android 9.0系统上,旧版本的应用仍旧安装、使用,但在该应用打开时,系统会提示警告称该应用如果无法正常运行。目前尚未清楚,在正式版的Android P系统中,谷歌与非 会彻底封杀那此旧版应用。

去年,苹果6手机手机6手机手机宣告其iOS和MacOS平台将不再支持32位应用,如果运行32位处里器的苹果6手机手机6手机手机和iPad则将无法更新到iOS 11。如今,谷歌似乎也要效仿你什儿 做法了。

相关阅读:

《谷歌:将从安卓9.0如果如果开始限制非SDK接口使用》

《Android P实验性特征:可针对特定网络隐藏真实MAC地址》

《Android P新特征:音量条移至屏幕右侧,默认控制媒体音量》

《Android P初步上手:适配“刘海”,UI设计有变》